Drink tea and make things

SMT Soldering and Atari ST Repairs

Yesterday I recapped my ST’s PSU which went well, nothing exploded. However when trying to boot the machine it kept crashing, especially when it went to the desktop.

The machine has an old Marpet RAM upgrade which has SIMM slots, and the contacts were looking a bit green. Thinking it might have RAM issuesI ordered a diagnotics cart which somehow turned up today in the mail. I’m sure I ordered it yesterday and not from Amazon…

The RAM tester on the diag cart showed weird things, like 520KB of RAM (not 512… 520…), but then if I had both of the SIMMs in the machine it shows 1MB of RAM which made no sense. The machine has 512K on the motherboard, and the two SIMMs should have been 1 meg each. I rememberthe machine having 2.5MB of RAM in it.

Cleaning the contacts on the SIMMs and socket fixed it, and when booting TOS2.06 it showed 2.5MB of RAM like I remember. The crashing was dueto the machine having no floppy drive connected. It seems it crashes in TOS2.06 if there’s no drive. It’s OK in TOS1.02 though.

I also discovered the Atari-PS/2 mouse adapter I bought works, but not with the PS/2 mouse I own. It worked fine with a USB Logitech Trackman Marblethough, that’s so old it speaks PS/2 as well as USB.

For the rest of the day I tried to learn how to hot air reflow surface mount components. I think I’ve got the technique somewhat sorted. It’s a bit fussy getting things lined up with just enough solder paste to solder but not so much it blobs up and makes the components do weird things like slideoff.

Oh and I painted the inside of the summer house. It needs more coats, but then the only thing to do is add some trim around the windows and acrossthe bottom of the walls. After that I can give it a good clean and it’s ready to be used.

Comments

Leave a Reply

Your email address will not be published. Required fields are marked *